Trouble with date extensions

Use this Forum to post your “How to …” questions about your use of aXes. This is not a technical support forum. Both the aXes Support Team at LANSA and other aXes customers may answer your questions. LANSA cannot guarantee the accuracy of any information posted by customers.

Moderator: jeanmichel

Post Reply
Joerg Hamacher
Posts: 23
Joined: 09 Mar 2016, 00:29

Trouble with date extensions

Post by Joerg Hamacher » 12 Jun 2019, 17:43

Hi,
we are working on a German IBMi system.
In our 5250 applications date fields are normally edited in format DDMMYY and displayed in format DD.MM.YY

E.g. when opening a 5250 screen the date (input field) is displayed as 12.06.19
In aXes I define this field as date (date extension) - but when I open the screen in aXes no date is displayed in the date field box.
After selecting a date using the calendar a date is shown in the box. After pressing the ENTER-button the date box is empty again and our program triggers the error message that no valid date was entered.

dateFormatDisplay / Edit / Server are "ddmmyy".



What can be done?

Many thanks in advance,
Joerg

User avatar
jeanmichel
Posts: 100
Joined: 23 May 2014, 11:37
Location: Sydney

Re: Trouble with date extensions

Post by jeanmichel » 16 Aug 2019, 11:40

Hi Jorg,

Apologies for the late reply on this one.
In the date format, you need to set the dateFormatServer peoperty on the date extension property to match the format you require (e.g. MM.DD.YY)
Unfortunately we do not have a matching setting as the one you are looking for.
You could request this enhancement to be added by emailing Lansa Support.
Regards,

Jean-Michel Rapin

LANSA Pty Ltd
email: JeanMichel.Rapin@lansa.com.au
Address: 122 Arthur Street, North Sydney, NSW 2060, Australia
Tel: +61 289 070 262 http://www.lansa.com | http://blog.lansa.com |

Joerg Hamacher
Posts: 23
Joined: 09 Mar 2016, 00:29

Re: Trouble with date extensions

Post by Joerg Hamacher » 20 Aug 2019, 18:15

Hi Jean-Michel,

thanks for your reply.

No problem with the time passed - everything's OK! Made me to get creative and to try the settings of date extension property values in between ;-)

I changed dateFormatDisplay and dateFormatServer to ENV.returnValue = "dd.mm.y" and dateFormatEdit to "ddmmyy" and now it works fine.


Cheers,
Joerg

tim mcentee
Posts: 17
Joined: 26 Jul 2017, 13:20

Re: Trouble with date extensions

Post by tim mcentee » 27 Aug 2019, 10:44

Hi Joerg

If you follow the JQuery dateformat documentation there are a lot of formats available that can be set via returnValue='dd.mm.y' etc

https://api.jqueryui.com/datepicker/#utility-formatDate

Tim

Post Reply