[aXes 4.1.0+] Troubleshooting when Data Explorer or Web Spooledfile is not working

Use this Forum to post tips and techniques for using aXes. Please explain in detail. This Forum is managed by the aXes user community. LANSA cannot guarantee the accuracy of any information posted to this Forum.

Moderator: jeanmichel

Post Reply
User avatar
jeanmichel
Posts: 96
Joined: 23 May 2014, 11:37
Location: Sydney

[aXes 4.1.0+] Troubleshooting when Data Explorer or Web Spooledfile is not working

Post by jeanmichel » 25 Oct 2017, 15:02

What to do when you get this message ?
errorde1.png
errorde1.png (2.84 KiB) Viewed 881 times

Keep calm!

Follow this step by step guide to find out what is the issue.

1) Check that the subsystem axes and axesjsm are running on your IBMi.
Dependig on your installation configuration you may have names those subsystems differently. However default configuration is subsystem AXES and subsystem AXESJSM.
de52501.png
de52501.png (52.64 KiB) Viewed 877 times


2) open the file on your IBMi located in /AXESJSM/jsm/instance/system/httpd.xml
write donw the listen port="XXXX".
If you have selected secure="true" the port="XXXX" will not be used an only the sslport="YYYY" will be active.
In this example the listen port is 5563 for all JSM services.
httpdxml1.png
httpdxml1.png (66.5 KiB) Viewed 878 times


3) Scroll down in the file httpd.xml to see the params for the Database Manager (DE) and Spool FIle Manager(SFW)
Of course the database.library should reflect the library in which your JSM Services are installed. This was set when you installed aXes.
See below for an example.
httpdxml2.png
httpdxml2.png (74.98 KiB) Viewed 878 times


4) If you have modified the httpd.xml file you need to restart the AXESJSM subsystem.

5) Open the file located in /axes/jsm/axinfo.json
And make sure the values are matching the ones we just set in the httpd.xml file.
In this example they should look like the below.
axinfojson1.png
axinfojson1.png (33.25 KiB) Viewed 878 times


If you click on the Data Explorer link on the axes homepage this should open the program window.
Please note as of aXes 4.1.0 Data Explorer is activated by default for all axes customers and does not require any additional licensing.
Please also note that Web Spooledfile still requires a separate licence to be activated. Hence if Data Explorer displays properly and not Web SpooledFile, it may be you require a license.

To check this,please open the following folder /axesjsm/jsm/instance/trace and sort by date and open the latest folder. Open with notepad the file called manager.txt in this folder.

And look for the following trace data:
manager: axes is session (5101) licensed
manager: webqueue is processor (AXES) licensed
manager: connector is processor (AXES) licensed
manager: longreach is processor (AXES) licensed
manager: database manager is processor (AXES) licensed
manager: spooled file manager is session (5103) licensed
manager: connector spooledfile is processor (AXES/SFMANAGER) licensed
manager: read http configuration: /axes410jsm/jsm/instance/system/httpd.xml
manager: start http instance 'WebServer', listen on port 5563 across all interfaces

The line in red shows that Web SpooledFile is licensed.

6) If you get the following error, the users automatic registration is not active.
DEerror2.png
DEerror2.png (39.37 KiB) Viewed 872 times
Open the httpd.xml file and find the line related to the parameter name autoregister and make sure the value is set to true. If you do not want your users to be automically registered, please sent this to no. IN the case where the autoregistration is inactive you will have to regsiter the users manually. Plesae refer to DE and WS admin guide.
httpdxml3.png
httpdxml3.png (75.34 KiB) Viewed 872 times
Regards,

Jean-Michel Rapin

LANSA Pty Ltd
email: JeanMichel.Rapin@lansa.com.au
Address: 122 Arthur Street, North Sydney, NSW 2060, Australia
Tel: +61 289 070 262 http://www.lansa.com | http://blog.lansa.com |

Post Reply